Codejack

A lifetime of coding challenges

It’s better to .Take()
It’s better to .Take()

Given a EFCore entity object that has a navigation property, and the schema is built for a one-to-many relationship, but you want a navigation property to represent a single record based on a specific filter.

Hello [cruel] world!
Hello [cruel] world!

I’ve been writing code for 35+ years. Sitting on this domain name for 15 of them. Time to give back. Time to start blogging. This blog site will be all about solving specific coding challenges that I bump my head up against on a daily basis. My main development environment has been .NET C# since... » read more